Contact Form 7 6.2: "Composer detected issues in your platform" (PHP 8.3 required)
Composer detected issues in your platform:
Your Composer dependencies require a PHP version ">= 8.3.0".
Short answer: Contact Form 7 6.2 needs PHP 8.3 or newer, and on older PHP it stops the whole site with this error. Switch the site to PHP 8.3+ in your hosting panel, or put Contact Form 7 back to 6.1.7, the last version that runs on PHP 7.4. If the site is down, rename the plugin folder first to get it back.
Why it happens
Contact Form 7 6.2 (6 October 2026) and every release since, up to 6.2.4.1 on 29 October, declare "Requires PHP: 8.3" and "Requires at least: 7.1". They also ship Composer's platform check, which runs before any plugin code and throws a RuntimeException on PHP below 8.3. WordPress refuses an update only when the PHP doing the update is too old, so a site can still end up running 6.2 on old PHP: an auto-update or a WP-CLI/cron job run by a newer PHP binary, or a multisite child site or subdomain served by an older PHP handler. Version 6.1.7 needs only PHP 7.4 and has no Composer check. We reproduced it on 31 October 2026: loading 6.2.4.1 on PHP 8.2.12 printed exactly this error and stopped with exit code 255; on PHP 8.6.0RC4 it loaded normally.
You may also see
PHP Fatal error: Uncaught RuntimeException: Composer detected issues in your platform: Your Composer dependencies require a PHP version ">= 8.3.0". You are running 8.2.12. in .../wp-content/plugins/contact-form-7/vendor/composer/platform_check.php:22
Fix
- Site down (HTTP 500 or this message on every page)? Rename
wp-content/plugins/contact-form-7tocontact-form-7-offwith your host's file manager or FTP. WordPress deactivates it and the site comes back; your forms and messages stay in the database. - Check which PHP really serves the site: Tools → Site Health → Info → Server → PHP version. If your host shows 8.3 but this says lower, the domain or subsite uses another PHP setting. Change it there too.
- Lasting fix: switch the site to PHP 8.3 or 8.4 in the hosting panel. First check your other plugins and theme; our free PHP Upgrade Readiness plugin lists what PHP 8.1 to 8.6 flag. Then rename the folder back to
contact-form-7and activate it. - Can't move off PHP 8.2 yet? Put back 6.1.7: download
https://downloads.wordpress.org/plugin/contact-form-7.6.1.7.zip, delete the renamed folder, then Plugins → Add New → Upload Plugin and activate it. With WP-CLI:wp plugin install contact-form-7 --version=6.1.7 --force. - Stop it updating again until you are on PHP 8.3: Plugins → Contact Form 7 → Disable auto-updates, and skip the update notice.
Download PHP Upgrade Readiness (free)
Which popular plugins log notices on PHP 8.6: our test of the top 100.
Watch out
- Contact Form 7 6.2 also requires WordPress 7.1. On WordPress 7.0 or older, update WordPress first, or stay on 6.1.7.
- Don't edit
platform_check.phpto skip the check. The plugin's code needs PHP 8.3 features, so it fails anyway, and the next update puts the check back. - 6.1.7 gets no new fixes. Treat it as a bridge until the PHP 8.3 move.
- Forum reports after 6.2.3 also describe forms that don't submit in some themes. That's a separate issue; we haven't tested it.
Sources
- Contact Form 7 6.2.4.1 readme (Requires PHP: 8.3, Requires at least: 7.1)
- Contact Form 7 6.2.4.1: vendor/composer/platform_check.php (the check that throws the error)
- Contact Form 7 6.1.7 readme (Requires PHP: 7.4, Requires at least: 6.7)
- Contact Form 7 on WordPress.org: Advanced view (older versions download)
- WordPress.org: Update PHP
Other errors breaking soon
- Unable to display RD Web Access: Chrome 158 and Edge 159 turn off XSLT
- Windows KB5127648: 802.1X Wi-Fi, wired and VPN sign-in fails (NTLMv1 SSO blocked)
- Firebase: Runtime Node.js 20 was decommissioned
- Firebase Hosting deploy fails: 403 "Permission denied to get service [firebasehosting.googleapis.com]"
- AWS CodeBuild: Unknown runtime version named '20' of nodejs
- Google Cloud Python: non-supported Python version (3.10)
- Azure OpenAI o1, o3, o3-mini and o4-mini retire on 19 November 2026: 410 Gone
- OpenAI: "The model … has been deprecated" or "Model not found" after a shutdown
- Biome 2.6: biome check fails on README.md and YAML files after the upgrade
- pytest 9.2: xdist_group tests run on different workers (--dist loadgroup)
- WordPress 7.2 ignores data-wp-init--, data-wp-watch-- and data-wp-run-- directives
- Ubuntu 26.04 upgrade stops with "Unable to upgrade MySQL" (mysql_native_password accounts)